CSD 4.41_001 Dante Firmware Update Manager - Failing to Update

Dear Kind CSD Folks,

Not sure if this is a bug or just another one of my excursions into the Twilight Zone. I’m thinking I hear Rod Serling’s theme song …

Last week, one of our contractors could not update a Dante card plugged into an ESP4120. Since I was theoretically on vacation, I asked Bruce to bail me out and I believe he ultimately decided to ask the contractor to send the card back for a replacement.

Today, I had a contractor with the same issue on an ESP1600. We connected with a switch, without a switch, tried running it from within CSD and from the FUM utility directly in the bin folder. We disabled wi-fi, power cycled the ESP, and later restarted the computer and again power cycled the ESP. Still no luck. The error message was something to the effect that “All Devices Failed to Update” and “Download Error”. These errors popped up almost immediately. It made no attempt to load the new firmware.

The contractor had CSD 4.1 available and thought maybe (like Crestron) he had to do an intermediary update. I didn’t think that would help, but I had nothing else to suggest at the moment other than to grasp at more straws. So I had him launch the FUM utility in the 4.1 bin folder and update to Dante Firmware 1.3.0. It loaded as it normally should. He returned to CSD 4.41_001 and it failed to update from 1.3.0 to 1.3.2.

I had him return to the CSD 4.1 bin folder and launch the FUM utility. This time, I asked him to browse for Dante FW 1.3.2 in the CSD 4.41_001 bundle and load it with the 4.1 FUM utility. It worked perfectly.

Since these “appear” to be exactly the same versions of the FUM utility, is there a possibility that something else is going on - like maybe a partial file corruption or some other mysterious computer type anomaly?

Best regards,