Bose Revolve battery won't charge

I have one Bose Revolve and one Bose Soundlink Micro.


The Bose Revolve is not working anymore. When I plugg the charger, an orange light keeps blinking, but no matter how long I leave it charging, when I turn on, it says "battery low, please charge now".


I've tried to use different outlets and I've tried to use the charger that comes with the soundlink micro, but I got the same result.

The Revolve needs about 1.5 amps to charge.  Computer USB and Monitor USB ports do not provide that.  I have had your situation 6 times.  The first time I thought it was the batteries on two Revolves and sent them in at $65 or so each for replacement.  It happened when they returned.  Then I sent them back for two brand new ones and it happened again to one of them four times.  Its NOT your battery - it is the fact IMHO that you messed things up somehow by charging on a computer or monitor.  Once you do that I have found, nothing will work.  It will get stuck at a certain percentage or even goes down while charging.  I personally believe it is a combination of too low an amperage coupled with a problem in the firmware (which shouldn't even let you charge on a 1 amp USB).  Again - you have to always charge from an outlet with a brick or using a USB battery charge on a port marked as 2 amp.  I have not had the problem reoccur in a few months now since I am careful - though no guarantees...

Bose will give you a process which may or may not work.  I have seen elsewhere here a process I use which is slightly different.

1. Permanently turn off the unit by holding down the multifunction key until all the lights blink.

2. Turn on the unit with the top on/off switch - you may need to hit it a couple of times or even turn it on plug in as described above.

3. Turn it off with the top switch,

4. Turn it on holding the top switch down at least 10 seconds to reset the unit but DO NOT answer the prompt.

5. Charge it until the green light comes on.

6. Turn it off and then on and follow the prompts.

If the above does not work, you may have to repeat it a couple of time.  I have found that in all 6 of my cases, it will eventually charge back to 100%

And then NEVER charge again in a 1amp computer or monitor USB.  NEVER!!! 🙂

I had trouble charging after my speaker had been unused for 1 year.  I only charged at 1.5A, but it would not keep charging (battery light would stop blinking).  I think it had trouble getting beyond a very low batter level.  The following helped (as per thread, thanks.  now it is charging with the light blinking):  


1.  Permanently turn off the unit by holding down the multifunction key until all the lights blink.

2. Turn on the unit with the top on/off switch - you may need to hit it a couple of times or even turn it on plug in as described above.

it isn't working after all.  It's still not charging.

Keep doing it - may require a bunch of times (exactly with the procedure I described).  You may want to try it sometime plugged in to a 2 amp USB sometime not plugged in (not sure that makes a difference...).  But if you get nowhere after a while, you may need to bite the bullet and get a battery replacement.  I don't recollect exactly but it was somewhere around $65 US (maybe slightly more).  All I can say is that a couple of times, I needed to repeat it a bunch of times until it made it to 100%.  No guarantees though... sorry....

To all Apple Mac Users ,

I had the same similar problem , The only work around was to

1> Go to the same link for Bose Updater , please find the Link below

2> Select the product which u own from the right corner drop down

3> Update the soft ware 

* But above all steps to be done in windows laptop machine only  that's the only work around Apple Mac are not supporting the existing app 

Also last but not least reset the speaker , please find the steps below to reset 

1> Remove the plug from the charging source in case if its in charging mode 
2> Turn on the Device 
3> Hold the ( . ". ) button on the speaker for 10 seconds until u see a flash of light appears on the LED and immediately release your fingers 
4> Then put it for charging , this works like a Boom 

RIP apple 

I have never charged my sound link revolve via computer, only ever in a wall socket, problem started when plugging into a wall socket to charge and it wouldn't. Followed all advice on bose community and had success a few times but now nothing works to cure the problem, even temporarily.


Sadly, this is most unsatisfactory for a product coming from a company with such a good reputation. Following the posts the problem is not new, four or five years old now, maybe more ! My speaker is guaranteed until 31st July 2021. 


It won't charge at all now, what to do next, I have no confidence in the product anymore ?

(I do not work for Bose)

Suggest you try the steps I have outlined elsewhere in this community.  Has worked for me every time (something like 8 times) though in some cases, I have had to repeat it a couple of times.


Hi, Thanks joelirwin, I have and I've got it working again eventually. Eight times ? I'm not that far yet, four or probably five times. 


There is a repetitive fault, many Bose clients are experiencing it, surely Bose should own it and eradicate it or recall the faulty material ?

Mines gone in for repair, let's wait and see !