Bose Soundtouch portable wont get past name in setup

I changed to a tp-link Archer 80 router and now I can not get my Soundtouch Portable to work. It will work on my old TP link TL-WR841N router but not the new one.

I have tried reinstalling both the app on the IPhone and my Macbook and setup from either and will not get past the Name the system section beforeI have a problem.

Have done resets, updates modem reset, deleted all security.

The wifi light will be lit properly, I can see on the router  that it is connected but still the app will not find the Bose.

I am on the same wifi network.

If I run my old router it will work

if I try on the old router used as an extender it wont work.

if I run it through a hot spot on the IPhone it will work.

Run on the 2.4 network on the router  it wont work

So I know it is something set on the router that wont allow it to function but cant find it...worked on this for 4 days now, about to trash it.








Hi Ronfire,


Thanks for posting and welcome to the Community!


If you are only unable to get the speaker working on your new router, then I do agree that it is likely a setting on the new router stopping you from using the speaker. I'd recommend starting by making sure the settings of the new router match our recommended router settings HERE, so it is optimized for use with the speaker.


Let me know how this goes!

I tried all the recommended settings in the link and still no luck. I could not find a " radio " setting


Thanks for going through this! Not all router settings will be the same or have the same titles, so don't worry that you can't find that section. At this point, I recommend contacting our support team via phone. This will allow for a much more complex dive into what's happening with the connection. Our team can even remote access in to see if anything can be tweaked. You can do this by clicking Global Contact Us > Select your country > Scroll to the bottom of the page > Click 'Contact Us'.



Let me know if you have any further questions.