Bose system EX-1280, 5 x PS404D, 16 x CC-2D - best IP practices?

Hello, first post here.

I am trying to pre-configure a system consisting of 1 x EX-1280, 5 x PS404D and 16 x CC-2D all connected to a Cisco CBS350-48 port PoE switch. I started a DHCP server and created a VLAN and a network pool. Everything works after uploading design from Control Space Designer - controllers, Dante, everything. But in a case of a switch reboot/power cycle, not a single device will get an IP, no mater of the settings - lease time, static reservations, etc.
So, after reading some time, I come to conclusion that I should remove the DHCP server, and add static addresses in CSP for every device. Can someone confirm which is the best practice in this scenario?
Thanks in advance.

Where do you run the DHCP server? In the switch itself?

There should be no problem with your setup. Devices that take their IP address from a DHCP server depend on the continued availability of the DHCP server, though; their IPs are said to be leased, rather than assigned, and they have a lifetime that depends on the DHCP server, but 1 hour is typical.

That said, if either you need to directly address your devices and don’t have or don’t want to resort to mDNS; or they need to talk to each other, need to find each other and don’t have mDNS; then you would be better off with static IPs.

Aside from that. If your setup doesn’t change often, then static IPs are one less moving part (the DHCP server) that needs to be up and running at all times, i.e., a single point of failure.

Hello, thank you for your answer.
I am using the DHCP server of the switch itself, yes, but it is not working as it should.
My guess is the Bose devices (especially CC-2D) are sending just one request when powered, but the DHCP server is not ready yet (after reboot) and it fails to give addresses.
I will make everything static and see how the system will behave.
I am still trying to figure out how to assign static addresses - when I disable the DHCP server, I can’t do it from the Cisco side - should I do it from the Control Space Designer?
Thank you!

Hi, if you want static addresses, then you set them up in each client device.

It is possible for the DHCP server to tie an IP address to a given device, but that would still be DHCP, so you would be back to square one on the issue of the devices not getting addresses.

So it seems that your solution is to go to each device’s admin console and assign a static IP.

Thank you once again, I will try to do that and will share the outcome here.


I assigned static addresses via Control Space Designer and Dante software, disabled the DHCP server and now everything works flawlessly. Thank you very much for the help!