ESP-880 Red Light after Firmware Update and Reboot

Bose product



United States

Firmware Version


App Version


Detailed description of the issue and steps to reproduce

When I went to update the ESP-880 it finished the download, and restarted. Upon restart no audio is passed through the unit and the "Power" LED is Red.

When did you start to experience the issue? Did it work correctly previously?

Audio passed through until I tried the firmware update.

Any troubleshooting steps you took

I have tried to use CSupdate with no luck, I scan but never see the ESP show up. I have power cycled the unit several times as well. I currently do not have an RS-232 serial cable to try at the moment. Hoping to have one shortly.


Hi Smitha,


Just to clarify, are you now unable to discover the ESP in ControlSpace?

If this is the case, please consider that the newest firmware in CSD 5.9 will set the default IP (if in DHCP) to link local. You can try by setting the PC to 'obtain IP automatically' and it should allow the option to update the project IP in HW manager. 


If you can still discover the ESP, but just can't go online or get rid of the LED, I'd recommend retrieving/saving the file (unless you have it saved) and loading a blank file to the ESP. If this clears the red LED, then re-upload the original design file again. 


Otherwise, as Guillaume suggested, you may need to reach out to us for other steps or service options.





I was using Wire Shark to moitor the connection between my computer and the ESP. After pushing the new update the the hardware it no longer shows up. I will try what you suggested and let you know my findings.



Hello again,


I have continued to try and get my ESP on line but I still can't connect to it. The Red led is till lit on the front of the device.

Hi Smitha,


Please let me know what you have tried as per my last message.




My apologies for the late reply. I am unable to see the ESP on my network, so I can't push any files to it. I was able to get a serial cable to try and connect as well but was unable to access the ESP.

Coming back to this topic after a while- the red LED usually means a file corruption. 

However, if you can't see the device, it could be back on it's default IP settings. 

This means DHCP, but without a DHCP service, it will take an IP of

If you put your network card on 192.168.0.x / and then start CSD, will it find the device? 

Ultimately, if it's still an issue, you should try to contact your local Bose Pro support group. (I'm not sure where you're located) 


Thank you,


Hi Mr Smith,


My name is Guillaume ROSSET.

I am part of the European Professional Technical Support.

I can surely help you on this issue.

Can you please contact me @ 331 30 61 65 23

Location : Paris, FRANCE

Best regards