Fetch TV not fully pairing to Soundbar 700 remote

I have just set up my new Soundbar 700 and had no trouble pairing the remote to my old Panasonic TV however when trying to pair the remote to my Fetch TV box it seemingly connects but only some of the buttons are activated. For example, I cannot use the remote to change channels or record a show - two pretty key features!

i have checked the community forums but can’t find any resolution to this. I’m really hoping it’s something I’m doing wrong and not a product flaw? My previous soundbar (Soundtouch 300) paired with my fetch tv box seamlessly, by simply entering a four digit code - is that an option still?


Any advice is appreciated. 

Sorry, I forgot to mention I’m in Australia

Hey Paul!


Thanks for taking the time to post your situation - I hope I can help you resolve this.


Have you made any other changes to your TV watching environment? As in, new cabinet, new area, different placement of TV/soundbar, or is everything positioned the same as before? It seems like you've been through the device set up on the Bose Music app which is correct - did it ever ask you to enter the device model number?

Hi Sam, thanks for replying.


I managed to get it working in the end - I tried each of the methods of connecting the Fetch box and the STB option worked.