Mesh router causes problems with soundtouch speakers

Today I noticed that my ST II speaker named Front was connect to my Kitchen group but there was no sound that came from the speaker. I checked my router and noticed that the speaker named Front was not connected to the Node in the livingroom but to the router and ..... the name was changed to it's default name Bose_Soundtouch D3.....( something like that ). I could disconnect and connect the speaker to the group and even was able to play the speaker alone with it's preset, but only after I changed the name in the router back to SoundTouch-Front I was able again to play all.


Did someone noticed strange behaviour with Mesh networks ? I have two RT-AC66U B1 ( one as Node in the bedroom and one as router in the hallway ) In the livingroom I use a Blue Cave as second Node. These strange things occur when I reboot the router and the client devices change from router to Node or vs.





Hey Rob, 


Thank you for your post! 


In regards to your query, Mesh networks are harder to use with our systems as it causes some difficulty with communication to our servers. 


Has this only happened on one occasion or are you continually having issues with your set up?


I look forward to hearing from you!

Hi Jessie,


I had a major problem when I switch to the mesh system and solved this by disabling Airtime Fairness on both bands. Seems that all multiroom audio systems seem to have a problem with this. Before I used the mesh system I used a similar Asus router with two TP link acces points and my old tablet had an issue with it's IP adres. When connected to my AP in the living room it's IP adres was similar with one of my IP camera's and there for I could not manage the ST speaker with the app on that tablet. This looks a lot like the issue I reported. All ST speakers are static and should be

 connected to the same node or router but off course after a reboot or power cycle from one off them the ST speaker will change it's connection. I did not receive any reply as you can see and also did not found any information on eg Asus forum or Sonos.  When I have an update I will share it with you and close this topic.





Hi Jessie,


Here is an update, I just updated your app and noticed the remark about playing AUX on all speakers and tried to play my TV' s SPDIF through the AUX input of my wireless link adapter. The result was the same there is a big lagg between the sound of my solo 5 ( connected to my WLA ) and my 2 ST20. Tried to play a CD this way and played well but I got that up and running almost a year a go, so the actual " update" was no news fort me. Untill ...... multiroom playback stopped and there was only sound on my solo 5 and both the ST20 were off ( clock was on the display ). Joining them back together did not work as expected only one off the two ST20 connected. My kitchen ST20 was not able to join the multiroom playback. The app showed that it was connected but no sound no nothing. I rebooted my router because I noticed that the wifi connection of the ST speakers was poor, after rebooting I found the cause. My ST 20 named SoundTouch-Kitchen was not connected anymore but it's original name Texas Instruments ( the wifi chip ) was connected. I made some screenshots after a view minutes the name SoundTouch-Kitchen was connected again with the same IP adres. During this proces I noticed that although the IP adres in the app was correct the name wasn't. Now everything is working like it should but there seems to be an issue with something like DNS that differs.

Did you get your speakers to work on your ASUS Mesh network yet? It's unclear.

I have sound control problems when arranging speakers into a group using ASUS mesh routers.


My speakers are working fine with the Asus Mesh network. My previous network was the same Asus router with two TP acces points which I got from my ISP. The Mesh network is better.