Not able to import DXF file


I am working on modeler 6.10 . i am facing one problem i have this DWG drawing i have converted into  DXF file  but not able to import in modeler.

Please can you advise .

Thank you David

But please can you explain me how you do it ???

for you 🙂 :-):-)

I'll chime in here a few tips about AutoCAD LT and getting a file suitable for import as an drawing layer in Modeler.

If there is any 3D objects in the drawing, Modeler assumes that the file is a 3D import and will only import 3D faces. So if there are any Solids in the file (and there were some in your file), you will  see nothing, unless of course, there are some faces in there. I usually just delete them, as they're generally just unimportant drawing details.

XRefs won't import either, and you must bind them to the main file. Then you need to explode them.

Blocks won't import, and must be completely exploded.

Hatches won't import either, and no workaround that I know of exists, but on the other hand, I don't miss them either.

Quick Select is your friend and can find most of these things. Don't forget to display and unlock your layers, so explode can work.

And sometimes on very complex drawings with a crazy amount of nested blocks, its easier to use the Dave Andrews method and create a pdf only to convert it back to a dfx.


Thank you to all of you.

Thank you Thommass.

Hi Masroor,

Just as a guess, it could be that the floor plan was an XREF and that particular portion of the file didn't make it to you with the original submission.  If you can get it from the source, you will likely be able to create the DXF file for import as intended.  If not - and you aren't that fussy over the exactness of a vector drawing versus a somewhat blurred and skewed raster image conversion, attached is something that you might be able to use in a pinch. 

Don't ask.  <smile>

Best regards,


Hi Masroor,

Attached is another one that retains the vector nature (cleaner lines - easier to use as a tracing layer).  I was in a hurry yesterday and didn't slow down enough for a cleaner image.  And of course, I forgot to turn off some of the unnecessary layers.  But you might find it more helpful.

The steps for the attachment I included here are easier (1-3 below) - the one I did yesterday that is more blurred used an alternate technique that - depending on the CAD file - can become necessary (adding steps 4 and/or 5).

  1. Open the file in AutoCAD, turn off (or delete) the layers you don't necessarily need for the tracing layer, rotate if desired, select (or create) a view port that has what you want to see in the window and print it to PDF (I always use grayscale or black and white).  In the PDF print utility (I use CutePDF Writer - but there are lots of them out there) choose a paper size to match the drawing size - like ARCH D or whatever works.
  2. After you save the newly created PDF version, open it up in a PDF to DXF conversion program.  I have Aide PDF to DXF Converter installed.
  3. After you convert it, you may be able to import it directly into Modeler.  You will need to scale it using a known dimension - it never imports with exact dimensions like a direct CAD import.
  4. There are times when you will try to import in Modeler and nothing shows up.  In these cases, open up the DXF file you created with AutoCAD, and resave it as a DXF file.  (Yes, this makes no sense - but you will discover that the file size typically increases and the resaved version will now import into Modeler with the surfaces viewable.)
  5. There are times when the above will not work - or you will get multiple DXF files - like stripes) that you can attempt to patch together in AutoCAD.  This being a royal pain in the posterior, you can resort to printing a hard copy and then scan the printed image to PDF - convert to DXF - open in AutoCAD and resave as a DXF file and voila' - you have an importable DXF tracing layer - that is a little messy looking, but still better than drawing a model completely freehand.

Now - aren't you glad you asked?  😉

Best regards,


I would also strongly suggest to delete unwanted layers (LayDel) and then Purge "ALL" the drawing before saving it as .DXF for Modeler. This will reduce the drawing size and will help faster loads in Modeler. Sometimes Modeler does not like having large guide layers! Hope this helps.

Hi Masroor,

please make sure you have also read the respective application notes on DXF import. I've attached them here since I actually had trouble finding them on and also the forum...

I also recommend to watch the video tutorials,  which are linked here.

And a forum search on 'DXF' will also bring up a number of useful discussions.

As you read above, to get really useful drawings, additional work is required in AutoCAD and it's recommended to learn some of its features, e.g. like described above, to streamline the work. Depending on how much detail is in the drawing, you may otherwise end up with really large model files which in the end, just slow down Modeler when it comes to file handling and DXF rendering.

Hope this helps.

Best rgds,