PM 8250 network & Bose remote app Wifi

Hello everyone,

Has anyone came across the following?

PM 8250 N (fixed IP) connected to wireless router, from laptop select WiFi network, ping accordingly to fixed IP, its OK. Launch controlspace & online the PM amp, its OK. Configure some psets to check, its OK. PM amp is online & i save a CSP file test.

Now i launch Remote App builder v2.0.3.8, configure the APP & save a new test.cpz. On my iOS smartphone, i select the network accordingly, launch controlspace remote app o my phone, select setup & enable receive control panel, on the remote builder, i key-in the IP address accordingly. The app was able to flash into my smartphone but the network status show offline-reconnecting. I power-cycle my laptop, the amp & my wifi router, re-do everything & name test2 (both csp & cpz), still the same.

So i proceed to check with another PM 8250 N, re-do a new csp & cpz & name test3, flash app to phone, its works! Check the app network status, its online & link icon shows connected.

What i don't understand is, the first PM 8250 N is able to online but WiFi APP refuse to connect, but with another PM 8250 N, it works fine.

Is there a possible issue on the network card?

Any comments? Thanks for reading my post.


Are you sure there is not a duplicate IP address?  Are all devices connected to the same DHCP server?

Hi Rschmid,

Thank you for your reply.

There are 7 devices connected to ASUS RT-AC88U, our PM amps are one of them and static IPs are in the same DHCP network. Client IP add is (gateway)

I actually setup my own wireless router, replicating the same IP address but no internet, the Bose remote APP works seamlessly. Now i began to doubt the quality of the client Asus wireless router.

Further checking with some IT friends, the QoS, IP range & firmware needs to be investigated. Though I am not sure if QoS & IP range could affect the WiFi quality, that i will need to look into, especially the Client wireless router. 

Do you think QoS & IP range could affect the quality & speed of the WiFi transmission?


I don't think this is a hardware issue.

1.  Are both 8250s attached to the same router?

2.  If so, does your project csp file contain both 8250s?

3.  If so, was the same csp uploaded to both 8250s?

4. If so, in RB did you load your csz file, import the csp, save the csz file (so the current csp is included in your csz) , quit RB, restart RB, open the csz and then send it to your Ios device?  


Have also having some problems with the App.

So for me it works for couple of days then one of the amps is offline in the app. 

My setup is: PM8250 and PM4250 are connected to the switch and then connected to Wireless router. Have set static IP for all devices and separate range for quests. No IP conflict.

After few days of work one of the amps is offline. Also the CS dont seem to get connection. Searching devices will show the devices (not every time)but when trying to link it says no devices connected. After many failed attempts I get the link but after unlink cant link again. Pinging the ip addresses have seen up to 3000ms mainly under 100ms. 

Also have hade a Error ID: -1  Fail in connecting Devices, Receive Timeout: XMLFileReceiveReq.

Have changed Switch and re-worked the IP addresses.

Any ideas what could be the problem.


Showtime - I agree that Bose's network connection between CSD and its devices is not very robust.  If a connection is lost, I need to cycle the power to the Bose equipment.  It does not reconnect on its own.  For this reason I generally use an ethernet cable to connect the PC running CSD to the router.  Wi-Fi is subject to interference from any number of sources.

However to me this appears to be a different issue than Berd's.  If I understand Berd correctly, he wants to create two remote builder apps to control two different PMs on the same network.  One app works, the other fails.   This is more likely an issue in his app, such as CSD file inconsistencies between the PM and the RB app, or perhaps using the same label more than once in the project.  For example, if you have a gain object and an equalizer object on the same input and name them both "input 1", remote builder does not return an error or warning but the app does not work.

For Berd, I would suggest uploading your csp and csz files and ask for help from someone @BOSE. 

Hi Rschmid,

Thank you for your reply.

My case is the same as Showtime, my intention is to create a simple app to manage all speaker volume connect to the amp.

As i mention, the Bose remote APP refuse to connect to the Client wireless router. I remove all LAN cables for our PM amps from Client router & plug in to my own wireless router, configure a new app for both csp & cpz, to be sure that I rebuild a new file for both, flash the APP & it works, again using MY wireless router. I have done this countless time in other installs, not my first time configuring Bose remote app. This case is still open as I cannot access the Client house till they are back from overseas trip.

I will get a switch for the Client network & I will flash the APP via a wired network, let's see how it works till then.

Same goes to the Bose Connect APP for all the SoundTouch, sometimes it just refuse to connect to the network, power cycle the wireless router a few times, only then it will work. 

Have a nice day.

we have a power match 8250N connected with CC-64 when the main power cut off , and when the power return on , why i should be upload the software again

Hello Ahmad,

You should not need to upload your design again.
When you say that you need to upload the software (I assume design?) again:

  • Do you see text on the display of the Bose CC-64?
    Are the Bose products connected to a switch or is  the Bos CC-64 directly connected to the Bose PM8250N (cross cable)?
    If connected using a switch, could it be that the Bose products are already fully started before the switch is?
    After about 20 seconds the Bose products stop checking if they can communicate with each other.
    Can you try to power cycle the system without turning off the switch?
  • Or do you mean that the design is still there, but after power cycle the settings are not the same as you programmed it?
    This could mean that the "Power Up State" in the properties settings of the PM8250N is set to "Restore Last Settings"
  • After start up, do you see in the top left corner of the Bose PM8250N display [DEFAULTS RESTORED]?

Which version of Bose ControlSpace Designer are you using and are all devices update to that version?


Thank you Arno for reply

no i don't see any text on the display of the Bose CC-64, the amplifier is connected to a switch with display. after power up ,the design program is still there There is no control by the display between the two products but i can still see the zones in the display but my problem is that i cant control the zones . that why should be upload the software again.