QuietComfort 35 II Firmware update - now recognized as a SoundLink Micro and not as Headphones

Bose product and related Apps / hardware used:


QuietComfort 35 II Headphones, Firmware Version3.0.3 - SoundLink Micro !?


Used PC, Android and iOS to try and resolve the issue. Most up to date versions of all Apps used.


Description of the issue:


Updated the Firmware for my QuietComfort 35 II Headphones.

It appears that the Firmware was overwritten by the SoundLink Micro Firmware.

The QC35 2 is now recognised as a  SoundLink Micro speaker.

I've uninstalled and reinstalled the Bose Connect App, unpaired all Bluetooth Devices and tried to run the update again.

Tried a factory reset of the Headphones, however as it thinks that it's SoundLink Micro, the factory reset steps don't work (The 2 devices have different reset methods, the speaker reset method cannot work on the headphones ...... the power button cannot be held in for 10 seconds, as it's an on off switch).

Connected the device to the PC and tried the Bose Software updater, once again, no success the device that it recognizes with the QC35 2 connected is a SoundLink Micro. The only Firmware updates that it will allow are those available for the SoundLink Micro (tried the Advanced menu in the Software updater).


Checked the FAQ's, contacted Bose and went through the issue with the helpline /  chat function, issue couldn't be resolved.


Assistance in how to resolve this issue will be appreciated. Can't understand why Bose can't push through an update to the device when it's linked to the PC or App.



Hello SilentSpeaker, 


Thank you for reaching out and welcome to the forums. 


This is very strange, and not something I have seen before. I would like to check, when you say you could not perform the reset, are these the steps you tried? Turn off the headset and wait 30 seconds and then plug the headset into a wall outlet using a USB charger, then wait 5 seconds. After that unplug the USB cord from the headset and wait 1 minute once you have completed this turn the headset back on? If so, could I please confirm, have you downloaded the Bose app on another device and tried pairing the headphones with it? Does it remain the same?

I look forward to hearing from you!

Hi Vicky,


Thank-you for the response.


Yes, I'd tried the factory reset option on the headphones, the 30 seconds, 5 seconds, 60 seconds, without success. I'd even timed it on a stopwatch.


I uninstalled the Apps on my Android and Apple Devices, unpaired all other devices and reinstalled the App, the issue persisted on all devices.


Tried the reset option again.


I then tried to run an update via the PC Bose Updater site, even found the advanced menu, same issue, the headphones are still recognized as a SoundLink Micro, with the suggested reset provided as the SoundLink Micro reset.



Still a SilentSpeaker