S1 Pro - Has Solid Red Light Even When Plugged In

My S1 Pro has a solid red light, even when plugged in.   When I unplug the unit from power and the switch is in the off position, the light stays red for about 15 secs.   FWIW, your phone support used to be EXCELLENT, now it is HORRIBLE!  I've bought your products for the quality and support, but I will think twice about buying Bose in the future.  As I type this I'm on my 3rd call trying to get help and I'm well over 20 min's on hold.  My last call about this unit I had the same experience, and it took several calls to speak to someone that could actually communicate.  

Hello, AGR.

Thank you for joining the Bose Portable PA Community.   I'm sorry you're having a problem (red light) with your S1 Pro system.

Is the solid red light on the front, or on the back beside the power switch? Have you done a system reset?

  1. Turn off the S1 Pro System
  2. Disconnect everything (audio, USB connections, Power)
  3. Remove the battery [3]
  4. Wait 30 seconds
  5. Reinstall the battery[3]
  6. Reconnect (audio, USB, Power)
  7. Turn on the power

Did that make a difference?

Please watch for a private message.

Thank you.

Bose Pro Community Admin

Hi, thank you for the quick reply.   It is on the back by the power switch.  


Have you tried a system reset?

    Turn off the S1 Pro System
    Disconnect everything (audio, USB connections, Power)
    Remove the battery [3]
    Wait 30 seconds
    Reinstall the battery[3]
    Reconnect (audio, USB, Power)
    Turn on the power


I have done the others but haven't tried removing the battery.  Mine came with the battery in place. I will check out how to remove it and give that a shot.  



I removed the battery and no luck.  I have everything disconnected, even bluetooth devices.  


Thank you for going through that diagnostic procedure.

Okay, that doesn't sound good. The unit will have to be serviced. I send you a direct message.  Look at the top right of the screen for a red dot. Click that, then click Private Messages.



Once I used this forum to report my issues, the service was top-notch.  Bose came through again and I much appreciate it.  A new unit is on the way to me.  Great job!  

I ordered the S1 Pro a week ago and now it gives me the red led and doesn’t charge.


what shall i do??

hello i am having the same problem 

Hi jvelarde, 

Welcome to the Bose forum! Sorry to hear you're having this problem with your S1 Pro. I recommend contacting the Bose Pro support team to discuss this issue in more detail and review available service options.