S1 Pro Service Port Not Working - Early 2018 Version

I purchased one of the early versions of the Bose S1 Pro.  Documentation indicates you need to update the firmware using the USB cable connected to the service port.  I also bought a 2nd S1 Pro a year later.  The 2nd S1 Pro I can connect to my MacBook and run the update successfully.  The original S1 does not recognize it's connected.  Same cable, computer and approach.  Tried removing battery, charging fully, different Windows computer with the same issue.  The updater does not recognize it's connected to the service port.  Please help!  I'm starting to think the 1st versions had different hardware or firmware and it's a hardware issue.  

Hi GuitarKing,

Welcome to the forum, thanks for joining us! 

I'm sorry to hear you're experiencing this problem. If you've tried a different cable and a different computer, this would certainly point towards the service port on the speaker itself being the root of the problem.

I recommend contacting Bose customer support and booking a repair to get this fixed. A software upgrade can also be performed as part of a repair service on the S1 Pro.

Hope this helps!

I also have exactly the same problem. According to Bose website, my serial number after Z is 8024 which is way less than 8162, this probably means my unit is one of those first bunch manufactured. I have tried at least 4 different cables, 3 windows computers (WinXP, 7), 3 different web browsers on each computer, clearing BT paired list, and many other methods, all without a luck. The web updater always stayed on the page reminding you to plug in usb cable and no further progress. I also tried using Bose connect APP on my phone, it did not detected S1 pro at all even Bluetooth is already connected to it.


I am kind of disappointed and frustrated now.

Hi Dunya,

Welcome to the forum! Thank you for joining.

I'm sorry to hear you're also seeing this issue. To have the S1 Pro speaker appear in the Bose Connect app, I recommend trying the following:

  1. Remove the speaker from your mobile device's Bluetooth list.
  2. Clear the pairing list on the S1 Pro system by holding the Bluetooth button down for 10 seconds until the Bluetooth indicator briefly turns off.
  3. Open the Bose Connect app to establish a new connection between your mobile device and the S1 Pro. 

As above, I recommend contacting Bose customer support and arranging a repair service to get the service port fixed.



Thanks for your suggestions. I already tried that. My speaker can connect to other BT devices and play fine. It just does not connect to Bose Connect App. I guess I am just gonna leave like that and I do not want to spend extra dimes on it.





I have the same issue.
Unfortunately, I am now in Nigeria where there is no Bose Support.


Mine is 8034

Hi DjBiso!

I'm sorry to hear you're experiencing this problem. When performing an update over USB, make sure you're using a micro-USB cable that also supports data transfer, as opposed to just a charging cable.