SoundTouch 10 Bluetooth issue after hard reset

SoundTouch 10


Firmware 26.0.1

App 26.0.5


Folks,  one of my SoundTouch 10 started acting out recently, it would turn off (dimmed WIFI indicator) and no buttons, either from the app or the speaker itself would turn it on.  The only thing that would bring it back to life was to unplug/re-plug, but the problem would come back after a few days.


I decided to try a hard reset, using the [1][-] device buttons and reconfigured the speaker.  When I first turned it on, I was able to set it in "bluetooth pairing" mode using the device's button, however, even though my device (PC) would register the speaker as connected, the speaker itself would not react, Bluetooth indicator keeping blinking in dark blue shade.  I tried unplug/re-plug again.


Now, neither the Bluetooth button on the device or the app shows any reaction.  I can use the web radio and I can set the speaker to "aux", but the latter can only be done through the app, as the button for WIFI/Aux on the speaker does not react at all.  Bluetooth through the app is also unresponsive.  I tried doing a Bluetooth list reset on the speaker, no avail. 


Thanks for whatever help you can provide. Regards,



Very sorry to hear that you are having this experience with your SoundTouch 10. Thanks for already looking into some great troubleshooting.


Out of interest do you get any alternate responses when using the product remote control opposed to the controls directly on the system? This way we can see if the system can read the controls. 


I look forward to hearing from you.



Thanks for the quick comeback!  Remote behaves same as speaker buttons or SoundTouch app: All buttons work except for the Bluetooth one.



Thank you for coming back to us! 


Based on the information you have provided, I would recommend updating the firmware. You can manually force the update by pressing and holding the 4 and volume minus buttons for 10 seconds. 


Let me know how you get on! 

Update took about 20 minutes.  Bluetooth button on speaker pressed once (not hold), pairing dark blue flashes.  Try to connect using both PC and mobile, no reaction from speaker.  Web radio functions, Bluetooth button doesnt react anymore on either speaker, remote or app.


Should I start consider replacement and if so, how can I proceed?



Sorry to hear this Senchin! 


As the issue still persists, I would recommend that you reach out to our regional customer support team via this link here. The team will be able to provide you with the necessary steps to proceed with service options. 



Going through the service request, I find out that I need to shell out 90 bucks to have my speaker repaired.  Given I had spent around 250$ for a pair of those speakers a bit over 2 years ago, this repair amount seems excessive. 


I went with Bose products back then for the renowned product quality and ease of mind, favoring your brand over Sonos.  As I expect such devices to have a normal life expectancy of over 24 months, I would really appreciate any efforts you can make to make this more palatable.


I was planning in expanding my wireless sound system (I currently own 3 Soundtouch 10, a SoundTouch 20 and a Bose SoundSport) buying a couple of your larger speakers and shuffling what I currently have around the house.  If this customer service experience persists, even though you personally gave me a great service, I will have to reconsider expanding my usage of Bose products.


Best wishes, and a very merry Xmas to all your support team.

Thanks for reaching back out to us Senchin! 


This isn't something that we can assist with via the Community as we don't have the customer support tools to look into this for you. When selecting the link we provided you with please visit the Contact Us page and give us a call instead of filling out the service form. The team will be able to provide you with all the service options that we can offer. 


We hope that you had a great Xmas also 😊

Will do, thanks a lot! Now go on vacation! 🙂