Soundtouch 10: Connected to wifi but app does not recognize it

Hi Everyone.


I have a Soundtouch 10 for a year now, and it has worked good until now.

Some days ago, it was not recognize for any app to stream. When i check the bose's app, it does not appear in the devices list.


I made factory reset and tried to configure it, but it fails in the process. The odd thing here is when i use spotify from my laptop, it recognizes the speaker, but when i try to stream from my phone o check it from Bose's app, it does not apear as device.

Every device here is connected to same wifi network: speaker, phone and laptop.


Thanks for your help

Hi demonmalfas,


Welcome to the Community! Thanks for joining us!


It is strange that Spotify on your laptop is able to find the speaker but not the SoundTouch app! When you are trying to set it up after the factory reset, at what point in the setup process does it fail? Does it give you any error messages at all?


If it gives you an error after naming the speaker, I've found this usually happens because the speaker requires an update. If you follow the instructions shown HERE you can manually update your speaker. I recommend using the USB cable method as I find this to be the easiest and most effective way to update when not connected to the app! If you are using a Windows laptop to do this, you may need to download the latest version of the SoundTouch app for Windows to make sure your computer has the correct drivers, this can be downloaded from HERE.


I hope this helps, let me know!



Thanks for your help.

¡Connecting the speaker via usb to pc did the trick!