SoundTouch Soundbar 300 & SoundTouch 10 setup failing and music not playing

I purchased both a Soundbar 300 and SoundTouch 10 and both  units no do not play SoundTouch music.  I went through the setup process multiple times with no luck. It keeps failing on the renaming screen, yet the renaming of the device appears to work fine.


I have tried the following and still cannot get music to play or the setup process to complete:

  1. Factory reset
  2. Setup by USB via the computer app
  3. Connecting both by wifi and ethernet (Soundtouch 300)
  4. Setup by the phone app
  5. Setup by the computer app
  6. Rebooting the modem and wifi routers several times
  7. Turning off all my wireless routers in the house except one and using just the one router
  8. Creating a new, separate wireless network just for the Bose speakers and connecting phones & Bose speakers to that
  9. Manually initiating setup on the Soundtouch 10 and connecting via IP address on my browser to set up the wifi using this approach: and  -- when I do this, it accepts and appears to connect to the wifi network but it does not have a "continue" button like it says in step 7.
  10. Removing both speakers from the SoundTouch app.  It won't let me remove them and hangs on the following screen:
    Screen Shot 2018-03-04 at 11.20.52 AM.png


Both the computer app and phone app always hang on the following screen.  I kept my phone and computer on for 30 minutes but this screen never went away.


Screen Shot 2018-03-04 at 11.06.58 AM.png


Here is the link to the system logs I found via the system log tool using the SoundTouch SystemLogTool:


This screen comes up quite a bit too in the SoundTouch app:

Screen Shot 2018-03-04 at 11.15.22 AM.png


I get this quite a bit too:

Screen Shot 2018-03-04 at 11.19.15 AM.png



My internet connection is very fast as well:

Screen Shot 2018-03-04 at 11.21.53 AM.png


Help would be greatly appreciated. I've spent several hours trying to get this setup to work and unfortunately it's not returnable.

Ok, further investigation revealed the following.


My internet provider company (cable) set up a cable modem and attached a wifi router system with 4 devices to it, then disabled the built-in wifi on the cable modem.  If I shut off the 4-device wifi router system and enable the one in the cable modem, both Bose systems work great.  


The wifi router system is an AirTies model Air 4920 (product link here).  The cable modem is a Hitron CODA-4582 (product link here).


All other devices work great on the AirTies network.  I'm sure if I contact my internet provider company, they'll say that the AirTies works just fine.


My theory is that since AirTies creates about a dozen wifi networks on varying bands but with the same name, that the Bose systems end up connecting to different sub-networks and therefore can't talk to each other.  


I tried setting up the network such that my phone app and the Bose systems are connected to the cable modem's wifi network and the AirTies system runs separately with a different password, etc. After I connect the AirTies to the cable modem with ethernet and enable the AirTies network, the Bose systems work correctly for awhile.  During the first few hours, I can change the SoundTouch station on them (e.g. from dance to jazz) and it will switch stations correctly.  After a few hours, when I change the station, the music stops playing, and the SoundTouch LED on the front blinks for awhile, then turns amber.  At that point, the app starts reporting all those errors like "Hmm... that didn't work" and "Hmm.. there was a problem checking for the update".  


So - the problem is with the AirTies network and the Bose systems apparently not being compatible.  I need the AirTies network to get fast  wifi speeds for my devices - I do videoconferencing at home regularly and without the AirTies, it drops out and coverage is poor. 


Is it possible to get the Bose systems to work together with my wifi setup?

Hi gkilwein,


Thanks for the information.  Is the only device you have for a router the Air 4920?  Do you have multiple of these mesh devices?


I wonder what kind of settings are on the AirTies network that we can take a look at.  Are you able to log into the settings page for your network?



Brandon - Bose Support

Hi Brandon, yes, I can log into both my Hitron router and the AirTies network admin settings page.  We have 4 total of the AirTies devices but the same problems happen even when running just one of them. Only one of the AirTies devices is connected to the Hitron router via ethernet. The others are all just placed throughout the house and plugged into electricity but nothing else.


Here are the settings screens in the AirTies settings system that might be relevant.

Hi again,


Thank you for the screenshots.  


It looks like the 2.4 and 5 GHz have the same SSID.  Can we change the 5 GHz so it is not the same as the 2.4 one?  Let's try this, and see if it helps the systems keep a connection to the internet.


Let me know what happens.




Brandon, that seems to have done it - it's working now.  Thanks! I'll follow up if there are any future issues.