Wave SoundTouch IV - unable to connect

I just bought a brand new Bose Wave SoundTouch IV. I installed the Soundtouch App on my smartphone, but I am unable to link them, in other words, I am unable to connect the system to the same wifi network as my smartphone. When I press the control button for a couple of seconds, the "wif-indicator" turns amber. But the screen does NOT say "Setup see instructions". It does say, however, other things, such as "Soundtouch not configured" or "Ready to pair".

Hello RR9400,


Thanks for posting and welcome to the Bose Community.


I'm sorry you're running into issues connecting your brand new Wave SoundTouch, but I'm happy to help.


During the setup process, when you were connecting your system to your Wi-Fi network, where you able to find and select your network in the SoundTouch application? Did it allow you to put in your password?


Also, how far are you from your router during the setup process? We usually recommend during initial setup to be within 10 feet of your router and after you can move it to its desired location.


Let me know the results.


Kind Regards,

Joel - Community Support



As it turns out, I could skip all these steps. I just had to link my smartphone (with bluetooth) to my Bose. So I did not have to through the relatively complex process as described by the App. A bit weird that the app did not explain this.  Anyway, the problem is solved!

Hello RR9400,


Thanks for the reply!


We're happy to see everything is resolved now and you can enjoy all the features your Wave SoundTouch IV has to offer.


If you have any other questions in the future, let us know.


Have a good day!


Kind Regards,

Joel - Community Support

Hi Joel, I just called product support about my Sound Touch not connecting.

Spoke with a rude buffoon who did not have a clue what the error code 1005 meant!

Years ago BOSE had native English speaking techinal people to walk you through connection problems. Not now, zero tech service, like their crude and failed Smartphone App shows that they are only a shadow of their former self.

Antiquated software, jokers at some Third World call center wasting your valuable time.
Sad to see BOSE drop so low and treat its loyal customers like trash in Third World gutter!


I bought a Wave Soundtouch IV yesterday and I am able to get it connected to my wifi but not to my soundtouch account. I recently got a new wifi router and was able to connect my soundtouch 10 to it and my soundtouch account. The new Wave and my soundtouch portable will not connect to my account tho..

How do i get these other 2 to connect to my account ? I have tried with my android phone, my wifes apple and my computer to no prevail.

I'dl like not to have to return the wave as the store is over an hour away from my home but if it will not connect then what good is it..and will purchase the google home. (never had an issue with those) 







Please see my post at the bottom i believe i have asked about my problem in the wrong space

Hi Faquer, 


Thanks for getting in touch and welcome to the community. I am very sorry to hear that you are having this issue with your Wave, however I would love to help. 


Can you please confirm that you have attempted all other troubleshooting methods that have been provided in this thread? 


Kind Regards, 

Hector B 



Yes i have tried everything in this post. I work in IT but this issue has truly stumped me.



Hi Faquer, 


Thanks for your post and fast response.  I would recommend taking a look and adjusting your router settings to rule out any connection issues. We recommend having these settings: 


  • UPnP: Enable
  • Multicast: Enable
  • IGMP: Enable
  • Wireless Isolation: Disable
  • IGMP Proxy: Disable
  • Wi-Fi Radio or Radio Mode: Mixed or B/G/N
  • Stealth mode: Disable
  • MAC Filtering/Access Control: Disable, or add the Bose system MAC address to allowed devices list
  • WPS: Disable

Kind Regards, 

Hector B